当前位置: 网站首页 > 股票软件公式 > 同花顺公式 > 文章 当前位置: 同花顺公式 > 文章

趋势线2021(同花顺公式)

点击: 次    来源:申博太阳城财经    作者:股市狙击 - 小 + 大

趋势线2021 源码是:

RSV1:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100;
RSV2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
WEN:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV (LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
J1:=SMA(RSV1,2,1);J2:=SMA(J1,2,1);
W1:=SMA(RSV2,3,1);W2:=SMA(W1,3,1);
强弱界线:49,POINTDOT,LINETHICK3,COLOR9966CC;
见顶信号:100,COLORCCFF00;
出点准备: IF(CROSS(J2,J1) AND J2>85,70,100),LINETHICK2,COLOR00FF00;
趋势线:= WEN,LINETHICK2,COLORFF84FF;
买点准备:IF(趋势线<=10,30,0),linethick2,coloryellow;
G1:W1,LINETHICK2,colorwhite;
G2:W2,LINETHICK2,colorcyan;
STICKLINE(趋势线>88,100,趋势线,5,1),colorgreen;
STICKLINE(趋势线<=10,0,趋势线,5,1),coloryellow;
STICKLINE(CROSS(J2,J1) AND J2>85,100,80,8,0),colorgreen;
DRAWICON(CROSS(趋势线,49),趋势线,7),colorred;
DRAWICON(FILTER(CROSS(G2,G1) AND G2>81,10),G2*1.05,2);
DRAWTEXT(CROSS(趋势线,30),30,"转强"),colorred;
DRAWTEXT(CROSS(49,趋势线),50,"转弱"),colorgreen;
Q2:=(CLOSE-LLV(LOW, 20))/(HHV(HIGH, 20)-LLV(LOW, 20))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
主力线:3*Q3-2*Q4,colorwhite,LINETHICK3;
跨越:EMA(Q3, 2),colorred;
VAR12:=(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))*100;
散户线: SMA(VAR12,3,1),colorgreen,LINETHICK2;
大底:=15,POINTDOT;
//DRAWTEXT(CROSS(主力线,散户线)=1 ,大底+30,'强势区域'),coloryellow;
VARD:=(ZIG(3,4)<REF(ZIG(3,4),1)) AND (REF(ZIG(3,4),1)>=REF(ZIG(3,4),2)) AND
(REF(ZIG(3,4),2)>=REF(ZIG(3,4),3));
DRAWTEXT((VARD=1),75,'必卖'),COLOR00FF00;
X12:=(C+L+H)/3;
BB13:=ATAN(EMA(X12,13)-REF(EMA(X12,13),1))*3.1416*10;
EMA8:=EMA(C,7);DRAWTEXT(FILTER(BB13>1 AND EMA(X12,13)>REF(EMA(X12,7),1),10),
EMA8,'∠45上升'),LINETHICK2,colorcyan;
//VARC:=(ZIG(3,15)>=REF(ZIG(3,15),1)) AND (REF(ZIG(3,15),1)<=REF(ZIG(3,15),2)) AND (REF(ZIG
//(3,15),2)<=REF(ZIG(3,15),3))AND (REF(ZIG(3,15),3)<=REF(ZIG(3,15),4));
VARD:=(ZIG(3,6)<=REF(ZIG(3,6),1)) AND (REF(ZIG(3,6),1)>=REF(ZIG(3,6),2)) AND (REF(ZIG
(3,6),2)>=REF(ZIG(3,6),3))AND (REF(ZIG(3,6),3)>=REF(ZIG(3,6),4));
//STICKLINE((VARC=1),(J),J+50,4,0),COLOR0000FF;
//DRAWTEXT((VARC=1),(J-0),'买'),COLOR0000FF;
STICKLINE((VARD=1),(H+65),20,4,0),COLOR00FF00;
DRAWTEXT((VARD=1),(H+75),'卖'),COLOR00FF00;
参考: IF(TROUGHBARS(3,70/4,1)=0 AND HIGH>LOW+0.01,20,-10),LINETHICK2,colormagenta;
卖: IF(PEAKBARS(3,15,1)=1,80,110),colorwhite,LINETHICK1;
VAR32:=100-3*SMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,34)-LLV(LOW,34))*100,20,1),15,1);
VAR33:=100-3*SMA((OPEN-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*100,20,1),15,1);
VAR2F:=VAR32<REF(VAR33,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR2F AND COUNT(VAR2F,30)=1,KDJ*0.59,'大资金观察'),colormagenta;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,50,'大资金活动'),LINETHICK1,COLORFF00FF;
STICKLINE(VAR11 AND COUNT(VAR11,30)=1,1,50,4,0),COLORFF00FF;
VAR12:=(HIGH+LOW+CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17);
VAR19:=IF(VAR18<90,VAR18,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,50,'大笔出货'),LINETHICK1,COLORFFCC66;
STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,0,50,8,0),COLORFFCC66;
//超短:IF(TROUGHBARS(2,7,1)=0 AND HIGH>LOW+0.01,20,0),colorbrown ,LINETHICK2 ;
抄底: IF(TROUGHBARS(2,40/5,1)=0 AND HIGH>LOW+0.01,30,0),colorred ,LINETHICK2 ;
VAR3:=PEAKBARS(3,60/9,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
顶A:IF(顶>REF(顶,1),55,0),colorgreen,LINETHICK2;
DRAWTEXT(顶A=55,H+65,'逃顶'),COLOR00FF00;
DRAWTEXT(抄底=20,H+50,'抄底'),colorred;
DRAWTEXT(FILTER(L<REF(L,1) AND C>REF(H,1),9),60,'短期高点');
D:=CROSS(ZIG(3,65/4)*1,MA(ZIG(3,65/4)*1,2))*1,colorred;
W:=CROSS(MA(ZIG(3,60/5)*1,2),ZIG(3,60/5)*1)*1,colorblue;
DRAWTEXT(W=1,10,'▼下跌确立' ),colorgreen;
DRAWTEXT(D=1,15,'▲上涨确立'),colorred;
F1:=ZIG(3,21);//股民学院 www.huzhuba.net
F2:=IF((F1> REF(F1,1)),110,85);
卖警:IF(PEAKBARS(2,7,1)=1,85,110),colorgreen;
泥淖:IF((F1> REF(F1,2)),110,85),colorgreen;
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
S1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;
S2:=今小前;
A1V:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));
A2V:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,33/4) ,REF(ZIG(3,33/4),1));
A3V:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,70/4) ,REF(ZIG(3,70/4),1));
STICKLINE(A1V AND A2V ,0,50,3,0),colormagenta;
STICKLINE(A1V AND A2V ,0,20,3,0),colorblue;
STICKLINE(A1V AND A2V AND A3V,0,65,3,0),coloryellow;
STICKLINE(A1V AND A2V AND A3V,0,28,3,0),colormagenta;
STICKLINE(A1V AND A2V AND A3V,0,10,3,0),colorblue;
DRAWTEXT(A3V=1,80,'必进!'),coloryellow;
DRAWTEXT(A2V=1 AND A3V!=1,55,'启动!'),colormagenta;
MA10:=MA(CLOSE,10),Color00BBBB;
MA30:=MA(C,30),colorred,LINETHICK0;
KS:=IF(MA10>MA30,MA10,MA30),,colorblue,LINETHICK0;
AA3:=(C-LLV(L,11))/(HHV(H,11)-LLV(L,11))*100;
AA4:=SMA(AA3,3,1);
AA5:=SMA(AA4,2,1);
AA6:=3*AA4-2*AA5;
AA7:=C-REF(C,1);
AA8:=100*EMA(EMA(AA7,6),6)/EMA(EMA(ABS(AA7),6),6);
买:=LLV(AA8,2)=LLV(AA8,7) AND COUNT(AA8<0,2) AND CROSS(AA8,MA(AA8,2));
DRAWTEXT(FILTER(买=1,4),70,'跟庄'),coloryellow;
BL:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
DRAWTEXT(FILTER(BL,3),75,'倍'),coloryellow;

上一篇:MACD亮剑,底背离 顶背离 低位金叉 二次金叉(同花顺公式)

下一篇:五轨布林(同花顺公式)